Startseite
Features
Changelog
Download
Kalender
Forum
Dokumentation
F.A.Q.
Newsletter
1&1-Shop
Kontakt
Impressum
Datenschutz

Social Bookmarks:
Teilen bei Facebook Bookmarken bei Google Twittern Teilen bei Delicious
(Icons by UIconStock)
Folge Event-List:
Facebook RSS-Feed

Logo

Du bist nicht angemeldet.

PaulB

Anfänger

Beiträge: 11

Level: 20 [?]

Erfahrungspunkte: 29 273

Nächstes Level: 29 658

  • Private Nachricht senden

1

Donnerstag, 7. Februar 2019, 10:52

Beschreibung von Einträgen nicht sichtbar

Hallo!
nachdem ich nach unseremletzten Austausch nicht wesentlich weiter gekommen bin, aber mit der Umstellung auf MySQLi (und PHP 7.1.26-he.2) - erstmal - arbeiten konnte, hat sich jetzt doch ein Fehler offenbart.

Und zwar wird die Beschreibung von Kalender-Einträgen nicht mehr angezeigt. Lediglich in der Ansicht "Editieren" taucht der Inhalt auf.

Ich hatte auch, wie Sie bei unserem letzten Austausch (siehe oben) empfohlen hatten, das Update auf 5.0.3 versucht. Allerdings mit einem "Fehler beim Datenbank-Zugriff".

Welche Vorgehensweise können Sie empfehlen?


Mit freundlichem Gruß,
EDIT: Ach übrigens, unter PHP 5 werden die Einträge angezeigt. Allerdings lässt der Provider diese Version (verständlicherweise) nicht zu. Könnte man (behelfsmäßig) vielleicht die entry.php & detail.php anpassen?

danton

Programmierer

Beiträge: 2 556

Wohnort: Ennigerloh

Beruf: IT-System Engineer

Level: 52 [?]

Erfahrungspunkte: 15 248 499

Nächstes Level: 16 259 327

  • Private Nachricht senden

2

Donnerstag, 7. Februar 2019, 11:30

Warum dieses Verhalten jetzt auftritt, ist mir gerade nicht ganz klar. Es gab keine Änderung von der 4.6 zur 5.0, die eine Korrektur dieses Verhaltens bringen könnte. Und da die Version 5.0.3 unter PHP 7 problemlos funktioniert (selber im Einsatz) habe ich keine Idee, was da was bringen könnte. Du kannst höchstens mal den Debug-Modus aktivieren, evtl. spuckt der ja was aus. Hast du außerdem auch mal in den Quelltext geschaut, ob die Beschreibung nicht vielleicht doch da ist und nur im Browser nicht angezeigt wird?
Ansonsten bez. Update und Datenbank-Fehler: der sollte eigentlich in acp/lib(logs(database_error.log verzeichnet sein.
Gruß
Markus

Programmierer von Event-List http://www.event-list.de

Support gibt es nur im Forum, nicht per Telefon, eMail oder Privater Nachricht
Bugs und Feature-Wünsche bitte im Forum melden!

Wenn Euch Event-List gefällt, schaut doch mal in meinen Amazon-Wunschzettel.

PaulB

Anfänger

Beiträge: 11

Level: 20 [?]

Erfahrungspunkte: 29 273

Nächstes Level: 29 658

  • Private Nachricht senden

3

Montag, 11. Februar 2019, 12:55

Hallo,
also der Debug-Modus hat auf einen veralteten Konstruktor der Klasse lib_pw_hash verwiesen, womit ich nicht viel anfangen konnte. Hatte in meiner Test-Umgebung kurz mit neueren Versionen dieser Klasse rumprobiert, aber das war nur ein Stochern im Nebel und hat zu anderen Fehlern geführt.

Jedenfalls habe ich dann nochmal versucht, das Update auf 5.0.3 zu starten, und siehe da: "Update Erfolgreich durchgeführt!" :)
Ich glaube beim letzten Mal hatte ich nur Version 5.0.0 versucht, oder habe eine Installation, statt Update durchgeführt... Kann mich nicht genau erinnern.

Aber egal... Version 5.0.3 läuft und das ist die Hauptsache.

Nochmals vielen, vielen Dank für die schnelle Hilfe!

MfG

danton

Programmierer

Beiträge: 2 556

Wohnort: Ennigerloh

Beruf: IT-System Engineer

Level: 52 [?]

Erfahrungspunkte: 15 248 499

Nächstes Level: 16 259 327

  • Private Nachricht senden

4

Montag, 11. Februar 2019, 13:14

Hallo,
also der Debug-Modus hat auf einen veralteten Konstruktor der Klasse lib_pw_hash verwiesen, womit ich nicht viel anfangen konnte. Hatte in meiner Test-Umgebung kurz mit neueren Versionen dieser Klasse rumprobiert, aber das war nur ein Stochern im Nebel und hat zu anderen Fehlern geführt.


Danke für den Hinweis, dann muß ich mir die mal anschauen und ggfl. für die 5.2.0 anpassen (falls ich das noch nicht gemacht habe) - ich hatte die Klasse seinerzeit (wenn ich mich recht erinnere) mininal angepasst, so dass neuere Versionen nicht ganz kompatibel sind.

Zitat

Ich glaube beim letzten Mal hatte ich nur Version 5.0.0 versucht, oder habe eine Installation, statt Update durchgeführt... Kann mich nicht genau erinnern.


Ich denke, es wird eine Installation gewesen sein - dann kommt es beim Anlegen der Tabellen zu einem Fehler, weil diese schon existieren. Aber schön zu hören, dass es jetzt funktioniert.
Gruß
Markus

Programmierer von Event-List http://www.event-list.de

Support gibt es nur im Forum, nicht per Telefon, eMail oder Privater Nachricht
Bugs und Feature-Wünsche bitte im Forum melden!

Wenn Euch Event-List gefällt, schaut doch mal in meinen Amazon-Wunschzettel.